1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

  2. The forum you are viewing relates to Kayako Classic. If you signed up or upgraded to the new Kayako (after the 4th July 2016), the information in this thread may not apply to you. You can visit the forums for the new Kayako here.

4.70 upgrade issue

Discussion in 'Installation and setup (Kayako Classic Download)' started by Techniker-Forum, May 27, 2015.

  1. Hi,

    get following error while upgrade to 4.70.0:

    Code:
    Fatal error: Call to a member function Get() on a non-object in /var/www/__swift/models/Settings/class.SWIFT_Settings.php on line 53
    What could it be?
     
  2. Gary McGrath

    Gary McGrath Staff Member

    Hi there,

    What version are you upgrading from?

    That error I think is actually an error with the cache ( try removing all the files within __swift\cache apart from the index.html file )

    Also, can you ensure to use the config.php file that comes with 4.70 ( rather than the one from your previous version ). As if the config file is too out of date, it can give issues.

    Gary
     
    Last edited: May 28, 2015
  3. Hi Gary,

    i am updating from 4.69.0 to 4.70.0.

    Cache is deleted since i rollout the new files and copy back attachments, config and key.
    Nevermind i found a workaround for me: It seems to be issues regarding PHP 5.5, have to disable error reporting in __swift/library/class.SWIFT.php:

    const DEFAULT_ERROR_REPORTING = 0;
     
  4. Phil R

    Phil R Established Member

    This is a problem here as well.

    With long standing threats to update from a older release, we now need to make progress on this. Due to platform inheritance, I don't know what if any changes internally have occurred, so I don't know what is going to break.

    Naturally, I am staging the platform in a dev box first so I can establish the process and problems.

    I have our old platform working file in this dev box. Hell, it was simple.

    However, I have put fusion 4.70.1 in place and I intend to run the setup against a blank DB, so I can run the pre-requirement tests such as PHP / memory settings and php modules, before I re-provision the files again using the our live config for the purpose of an upgrade.

    As such, I am using a "fresh" 4.70.1 installation, with PHP 5.6.9 with MariaDB on CentOS 6.6. The key is in place and the config is also in place pointing to the correct separate DB just to initiate the installation.

    This get's us:

    Code:
    PHP Fatal error:  Call to a member function Get() on boolean in /var/www/domains/evaluate.wandisco.com/kayako_4_70_1/__swift/models/Settings/class.SWIFT_Settings.php on line 53
    We got the non-object error due to having an older version of PHP on the box (which was originally there due to a mirror of our live env). Switching off error reporting (done solely as a test) did not assist, it only removed logging.

    Switching back to PHP 5.5 returns the non-object error and again error reporting does not help.

    I have followed through most of the pre-requirements with exception of some system specs (as this is a lab box), but this is not having any joy.
     
  5. Gary McGrath

    Gary McGrath Staff Member

    Hi Phil,

    I had a quick chat with other support staff and we think its actually down to a DB connectivity issue. I can see your using MariaDB and not MySQL. ( I know its meant to be fully compatible ), but it might be the cause of the issue.

    Can you submit a ticket at support.kayako.com as I think we will need to take a direct look to understand where your error is coming from.

    Gary
     
  6. Hi Gary,

    I'm running MySQL and got the same error...
     
  7. Phil R

    Phil R Established Member

    Hi Gary,

    I am currently on with Chirag over a Webex. He is seeing the same issues after we switched out Mysql (which I didn't think was an issue, but appreciate the need to check)

    There is certainly more to this.

    We have resolved all pre-requirements we skipped, such as max exec time (again, only left low as it's intended as a "can this display")
     
  8. Gary McGrath

    Gary McGrath Staff Member

    If you can both submit tickets at support.kayako.com we will take a look directly, its not a known issue, so we will need to investigate it to see what's happening

    Gary
     
  9. Phil R

    Phil R Established Member

    With a fantastic amount of time and a lot more patience, we have got to the root cause.

    We had uncommented to use the SQL Socket, but had not updated the path. Commenting this back out and moving to a TCP socket resolved this.
     
    Jamie Edwards likes this.
  10. Hmmm, seems another issue for me, not using sockets. Was this the part of your config you uncommentet:

    //define('DB_MYSQL_SOCK', '/path/to/socket/mysql.sock');
     
  11. Phil R

    Phil R Established Member

    Yes,

    With that uncommented, or following some subsequent testing to prove the issue, incorrect DB values, this error occurred.
     
  12. BaselAlkaddoumi

    BaselAlkaddoumi New Member

    Hi , All

    i Tested a lot of things , the fix will be by using the new config.php file that comes with the upgrade file ,just refill all info that is related with your DB
     
  13. Mehra

    Mehra New Member

    Just tried an upgrade to 4.71 (August 27th release) and the same error.

    Using MySql. Deleted cache, tried with a virgin new config.php from the new version archive, no sockets, php 5.5 (remi) on CentOS 6.4

    The const DEFAULT_ERROR_REPORTING = 0; fix only got me to being able to see the setup/index.php license page, with the actual license text missing and then failed with an "Error" on the very next page of the upgrade script.

    Seems its a bug that is persisting or did anyone get past it?
     
  14. Gary McGrath

    Gary McGrath Staff Member

    Hi there,

    Please contact support at support.kayako.com and we will take a look for you.

    Gary
     
  15. twhiting9275

    twhiting9275 Established Member

    Hi there,
    Instead of telling everyone to contact a support desk that ignores tickets, please post the actual fix for the issue publicly

    Better yet, fix the code so that this doesn't come back up. There's a unique thought

    Thank you
     
  16. Gary McGrath

    Gary McGrath Staff Member

    Hi there,

    The reason I asked them to contact support is that we needed to actually jump onto his server to see what was happening. A blank setup page usually means that PHP is missing some key modules, or has inappropriate settings for some of the PHP constants. I could have asked to see the PHP error logs, and worked out from there what was likely missing, but I thought it would be much easier to contact support so we could check it over ourselves.

    When you host Kayako yourself, it is important to understand the versions of PHP and how they can affect the configuration needed, for example MySQL and MySQLi depending if you are using PHP 5.5 or below, or 5.6. There are also issues with SSL certificates if using the later builds of PHP. All of these things are not actually "kayako errors" but misconfigurations of the hosting environment which just happen to impact Kayako.

    So for these cases, it is usually easier for us to jump onto your server, to see what has gone wrong.

    Kind regards,

    Gary
     
  17. Lionel GRARE

    Lionel GRARE New Member

    Same error here: "Fatal error: Call to a member function Get() on a non-object in /var/www/kayako/__swift/models/Settings/class.SWIFT_Settings.php on line 53".
    Our server configuration: fresh install of a TurnKey distrib (PHP 5.4.4 , MySQL 5.5 and Apache) on a virtual server.
    I'm trying to make a new installation (4.71) of Kayako (prior to migrate our old version 4.40 on it) but i got the error mentionned above.
    It seems that we are not the only one with this error. Is there a fix? a workaround? a setup tip?
    Thank you
     
  18. Gary McGrath

    Gary McGrath Staff Member

    Hi there,

    You can contact our support at support.kayako.com and we can take a direct look at your server for you.

    Gary
     
  19. supportskins

    supportskins Kayako Guru

    I am seeing this error too:

    Fatal error: Call to a member function Get() on a non-object in /home/insurplancov/public_html/__swift/models/Settings/class.SWIFT_Settings.php on line 53

    Any fix suggested? Error started popping after a system upgrade.
     
  20. supportskins

    supportskins Kayako Guru

    Just for others benefit, the issue was due to MySQL connectivity issue.
     

Share This Page