1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

  2. The forum you are viewing relates to Kayako Classic. If you signed up or upgraded to the new Kayako (after the 4th July 2016), the information in this thread may not apply to you. You can visit the forums for the new Kayako here.

4.70 upgrade issue

Discussion in 'Installation and setup (Kayako Classic Download)' started by Techniker-Forum, May 27, 2015.

  1. z33k3r

    z33k3r New Member

    Just to update other Googlers like myself: It's related to your config.php. Set your DB_TYPE to "mysqli" instead of "mysql"

    Code:
    /**
    * ADODB CONNECTION TYPE
    */
    define('DB_TYPE', 'mysqli');
    Original answer found in this thread.
     
    Last edited: Dec 11, 2015
    Jamie Edwards likes this.
  2. Vi Wizard

    Vi Wizard New Member

    Yes - I found that the __swift/config/config.php DB_HOSTNAME setting should be 'localhost' not '127.0.0.1'
     
    Gary McGrath likes this.
  3. jnugent

    jnugent New Member

    I have PHP version 5.6.17 and am trying to upgrade to 4.72 and am not able to get past this same error.

    Code:
    Fatal error: Call to a member function Get() on boolean in /var/www/html/...myurl.../__swift/models/Settings/class.SWIFT_Settings.php on line 53
    My config.php has what seems to be a fix for this:

    /**
    * ADODB CONNECTION TYPE
    */
    define('DB_TYPE', (PHP_VERSION >= 5.5 && extension_loaded('mysqli') ? 'mysqli' : 'mysql'));

    But again, still having this issue. Any other help?
     
  4. supportskins

    supportskins Kayako Guru

    Check if your MySQL access details are correct.
     
  5. jnugent

    jnugent New Member

    Thanks for the reply. They should all be correct. It's the same database credentials (host name, username, database name, password) as I had before in the config.php file. I'm upgrading from Kayako version 4.50 I believe. Is there anything specific I should be looking for?
     
  6. Gary McGrath

    Gary McGrath Staff Member

    Hi there,

    If upgrading from 4.50, you need to ensure you have removed all previous helpdesk files/folders, rather than just overwriting them. ( as we changed the framework quite significantly )

    Make sure not to delete your __swift\files folder however ( and ensure its backed up ) as it contains your attachments on tickets.

    Gary
     
  7. kohnout

    kohnout New Member

    NO NO NO. Installing brand new 4.70 and in the log (Debian 8 + ISP Config with PHP 5.6.9-0+deb8u1). I also have this same problem -
    class.SWIFT_Settings.php on line 53. MySQL data are perfectly correct. Connection type is with mysqli.
    There is definitelly problem with "cache settings" on line 53 of swift settings.

    Could you post solution or you will still wait for how many people will be angry from this???
     
  8. kohnout

    kohnout New Member

    Sorry, installing 4.71 not 4.70.
     
  9. kohnout

    kohnout New Member

    Hello, could you reply please???
    Solution - not "create ticket". This problem was born in 2015!
     
  10. Gary McGrath

    Gary McGrath Staff Member

    Hi there,

    If you are having issues installing Kayako and receiving the error above, it means that Kayako was not able to login to your MySQL server correctly ( for some reason ). The quickest way to fix this is to contact us at support.kayako.com either by creating a ticket, or using our live chat. We can then hop onto your server to see what is causing your issue.

    Gary
     
  11. kohnout

    kohnout New Member

    This is it. Company producing helpdesk software can´t help. Forum is for sharing SHARING SHARING. So many people asking for solution and you didn´t find any? DB connection data are ok so if kayako is not able to connect it is kayako´s problem. But I still think this is about CACHE folder, not DB.

    Btw. I tried fresh 4.71 installation on server where older kayako is running without problem and guess what. The same problem!!!

    POST SOLUTION HERE.
     
  12. Gary McGrath

    Gary McGrath Staff Member

    Hi there,

    I can understand your frustration, but this forum is not the place for you to get help you need. There can be any number of reasons that Kayako is not able to connect to your MySQL database ( configuration, environment, software versions, files and permissions ). All of those lead to the error you have mentioned you are getting. There is no "one answer fixes all", there is something wrong with your hosting setup, if you don't let us log in to check for you, it is not really possible for us to give you help.

    If you want to try and diagnose the problem on your own, I would recommend starting with checking your php error log and ensuring your setup meets our server requirements.

    Gary
     
  13. kohnout

    kohnout New Member

    No is not because:
    1. Using old config.php file with the new files ('__swift/config/config.php' file contains database connection information). I install new 4.71 version from the scratch so I have no old config.

    2. Incorrect database details in config.php. These details can be easily verified by logging in to MySQL command-line interface using the following command (substitute actual database information): I tried to copy and paste all DB data from config to another application. The connection worked.

    mysql -h DB_HOSTNAME -u DB_USERNAME -p DB_NAME (enter DB_PASSWORD when prompted)

    Note: If '127.0.0.1' is specified for 'hostname' under 'config.php' file, than please try after specifying 'localhost'. Yes, I have localhost. Tried both.

    3. If the version of your PHP is '5.5.x' or above, make sure that 'MySQLi' and 'MySQLnd' module is enabled for your PHP installation.

    Also, please check that your server has all the prerequisites configured, which are required for the latest Kayako version. You can find the complete list of prerequisites for the latest version here:
    https://kayako.atlassian.net/wiki/display/DOCS/Server requirements DOne, all set.

    4. The mentioned error may also occur if the permissions are set not according to one detailed in below URL:

    https://kayako.atlassian.net/wiki/d...desk#Installingthehelpdesk-Setfilepermissions All is OK regarding to requirements.

    And the problem is still there with single error in the log:
    Fatal error: Call to a member function Get() on boolean in /var/www/html/...myurl.../__swift/models/Settings/class.SWIFT_Settings.php on line 53
     
  14. We had the same issue. The problem was related to php56w installing php56w-mysql instead of php56w-mysqlnd. Once we removed php56w-mysql and installed 'php56w-mysqlnd' the issue was resolved.
     
  15. same issue here
    PHP message: PHP Fatal error: Call to a member function Get() on boolean in __swift/models/Settings/class.SWIFT_Settings.php on line 53" while reading response header from upstream

    when performing clean install 4.72
     
  16. supportskins

    supportskins Kayako Guru

    Make sure your database information is correct.
     
  17. not working with mariadb 10.1.16 + php5.6.23 + nginx 1.10.1-1

    but updated fine on mysql 5.5.46 + 5.4.45-0 + apache 2.2.22-13
     
  18. Fezile

    Fezile New Member

    My issue happened to be a password issue, for some reason mysql wanted me to reset the password inside mysql

    So I had to login:
    mysql -ukayako_user -pdifficultone

    and then:
    SET PASSWORD = PASSWORD('difficultone');
     
  19. cmonteiro

    cmonteiro Member

    Just got past it. For me it was a problem with SELinux and its various contexts. :)
    Had to change the context for the folders that need 777 permisions.
     
  20. Alex Saavedra

    Alex Saavedra Member

    A spare testing environment died with this error after applying Linux security updates. Changing DB_HOSTNAME from 127.0.0.1 to localhost in config.php solved issue:
    PHP:
    define('DB_HOSTNAME''localhost');
     
    Last edited: Jul 12, 2017

Share This Page