1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

  2. The forum you are viewing relates to Kayako Classic. If you signed up or upgraded to the new Kayako (after the 4th July 2016), the information in this thread may not apply to you. You can visit the forums for the new Kayako here.

4.73 to 4.77 Upgrade Failed

Discussion in 'Installation and setup (Kayako Classic Download)' started by Rodd, Nov 29, 2019.

  1. Rodd

    Rodd Member

    I am doing a test migration to a new host. Initially, i was getting 'unable to modify header' so i patched up to 4.77 as per another forum. first time, upgrade went smoothly, but i noticed an empty table, so i wiped the database and had the host import it via SSH

    i wiped all the files and re-copied everything and re-patched. this time, i get:

    Uncaught Exception
    SWIFT_AppLog: Object could not be created in ./__swift/models/App/class.SWIFT_AppLog.php:102
    =================================================================================================================================

    #0 ./__swift/library/Setup/class.SWIFT_SetupDatabase.php(1305): SWIFT_AppLog::Create(Object(SWIFT_App_core), 3, '')
    #1 ./__swift/apps/core/config/class.SWIFT_SetupDatabase_core.php(214): SWIFT_SetupDatabase->Upgrade(false)
    #2 ./__swift/apps/core/setup/class.Controller_Upgrade.php(472): SWIFT_SetupDatabase_core->Upgrade()
    #3 ./__swift/apps/core/setup/class.Controller_Upgrade.php(342): Controller_Upgrade->_RunStep2()
    #4 [internal function]: Controller_Upgrade->StepProcessor()
    #5 ./__swift/library/MVC/class.SWIFT_Controller.php(371): call_user_func_array(Array, Array)
    #6 ./__swift/library/App/class.SWIFT_App.php(176): SWIFT_Controller::Load(Object(SWIFT_Interface), Object(SWIFT_App), Object(SWIFT_Router), false)
    #7 ./__swift/library/class.SWIFT.php(16): SWIFT_App->ExecuteController(Object(SWIFT_Router))
    #8 ./__swift/library/class.SWIFT.php(16): SWIFT->Initialize()
    #9 ./__swift/swift.php(16): SWIFT::GetInstance()
    #10 ./setup/index.php(29): require_once('/home4/colleei7...')
    #11 {main}
     
  2. bear

    bear Kayako Guru

    How does one "patch up to 4.77"? Typically that's done by downloading and installing the paid version directly from Kayako that you're updating to.
     
  3. Rodd

    Rodd Member

  4. bear

    bear Kayako Guru

    That line appears to be related to a database insert. Is SQL running in strict mode, by any chance?
     
  5. Rodd

    Rodd Member

    when i run this:
    SELECT @@GLOBAL.sql_mode;
    SELECT @@SESSION.sql_mode;

    they both come back as the default: NO_ENGINE_SUBSTITUTION
     

Share This Page