1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

  2. The forum you are viewing relates to Kayako Classic. If you signed up or upgraded to the new Kayako (after the 4th July 2016), the information in this thread may not apply to you. You can visit the forums for the new Kayako here.

Apache, PHP, LoginShare, Kerberos

Discussion in 'LoginShare' started by Star Fox, Mar 1, 2016.

  1. Star Fox

    Star Fox New Member

    HeYa

    In my Kayako-Case Setup everything works fine - except SSO. I've got this configuration:
    - Ubuntu
    - Apache 2.4.7
    - PHP 5.5.9

    For ldap authentication in staff-area I installed the modules mod_authnz_ldap (and dependencies) and everything works fine with LoginShare.

    As I wanted to start providing Self-Service for the End Users (in the same Domain, Kayako only used internal), I decided to provide them an SSO solution. So I started reading tutorials and ended up with installing the mod_auth_kerb module (and dependencies) on my Server.

    After configuring everything correctly (biggest part was Apache.conf) it seemed to work but not as excepted. So actually I got REMOTE_USER variable from the visiting Users but was no more able to log in using LoginShare.

    I tried everything but nothing worked to get this running. So I decided to roll back Apache.conf and everything was going to be finde again - except SSO.

    So this is my Apache.conf (no Errors while running it):
    <Location />
    AuthType Kerberos
    AuthName "Kerberos"
    KrbAuthRealms MY.DOMAIN
    KrbServiceName HTTP
    Krb5Keytab /etc/kerberos.keytab
    KrbMethodNegotiate On
    KrbMethodK5Passwd On
    KrbLocalUserMapping On
    KrbVerifyKDC Off
    KrbSaveCredentials On
    require valid-user
    </Location>

    If I uncomment the lines, System is running properly and provides REMOTE_USER for further steps. But If I try to Login using Loginshare (where the LDAP Connection is configured correctly) I get the error: Invalid data provided: 2

    I just checked the returned XML but it Looks fine, no Errors.

    Any ideas? Thanks for your help :)

    Star
     

Share This Page