Automation errors

Discussion in 'Using the new Kayako' started by Phil R, Jul 7, 2016.

  1. Phil R

    Phil R Established Member

    Whilst building up the sample workflows in the trial, I noted an error whilst submitting a note.

    Quick background to the setup.

    Trigger 1:
    Condition: "Cases: Team", "not equal to", "Gold (PST)"
    AND Condition: "Organisation: User Group", "equal to", "Gold (GMT)" (User Group is a Organisational Field)
    Action 1: "Cases: Team", "Change", "Gold (PST)"

    As you may have noted from previous posts, this tried to mimic some of our workflow, by enforcing a team being allocated to a Case (a SLA is then setup, with a condition based on the team, attaching the SLA to the Case).

    However!! I see a problem with one of my cases (for ref my test account is backsythsla, case 2).

    When I attempted to add a Note to the Case, I get a error pop up saying "organizationfields.user_group not found in context". Secondary tests show this also happens when I change status for example.

    I can see why this happens, as said Requester is not assigned to an Organisation, which has clear implications to the trigger above.

    When trying to add the note, the content I attempted to add still shows in the editor and does not show as added to the timeline. Yet refreshing the screen clearly shows it was added (and does not show till I refresh, but the editor is still showing my note I tried to add).

    I explored if this can be worked around, such as other conditions on the trigger. e.g. is Organisation is NULL, but there are no conditions for this.

    upload_2016-7-7_16-17-43.png
     
  2. Jamie Edwards

    Jamie Edwards Staff Member

    Thanks for sharing that Phil - I the engine is strictly doing the right thing here, but it should fail gracefully - not stubbornly! We'll get a fix out for this tomorrow.

    Would you like to get on a call with one of our customer success managers to talk through your workflow plans and goals?
     
    Last edited: Jul 7, 2016
  3. Phil R

    Phil R Established Member

    Thanks for the offer.

    Yes and no. I will contact you in private around this.
     
  4. Jamie Edwards

    Jamie Edwards Staff Member

    Hey Phil - we don't have a fix out just yet, because we're extending the resolution to all sorts of different fields that should simply return false, rather than error out (in your particular case, it looks like you deleted the custom field which you were evaluating in your rule). Will be out shortly.
     
  5. Phil R

    Phil R Established Member

    Nope, I have not deleted the field that I recall, there is a field still there by that unique name.

    The only thing I cannot recall is if I have deleted if and recreated it. i.e. is there an underlying GUID that is involved and changed?
     
  6. Jamie Edwards

    Jamie Edwards Staff Member

    That's interesting - did you disable the field, then?
     
  7. Phil R

    Phil R Established Member

    I have done a lot of things with it I can't remember in the last 72 hours :p

    I have disabled and re-enabled some things, but I cannot state I did it for that field specifically.

    What I can say for certain is that I have not dis/enabled that field within the 10 minutes prior to hitting that error, nor at any point since getting the error.
     
  8. Jamie Edwards

    Jamie Edwards Staff Member

    Ok, cool. Well, the fix is out now so you shouldn't hit that error :)
     
  9. Jamie Edwards

    Jamie Edwards Staff Member

Share This Page