1. This sub-forum relates to Kayako 3, which is now end-of-life. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (no longer applicable).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

BlackBerry Ticket Client for Kayako

Discussion in 'Apps' started by craigbrass, Apr 19, 2009.

  1. mariow

    mariow Member

    paid but no license

    After a few days i thought lets buy Ticket client and so i did 2 hours ago.
    but nothing happend...

    i did saw a message saying..

    Unfortunately, it has not been possible to confirm if your payment was successful. Please keep checking the invoice status on the My Invoices page. If the status hasn't changed in 1 hour, we suggest that you contact our customer services department.

    so ive send a ticket one hour later....
    suddenly a reply...(probably automated)

    saying...You recently tried to placed an order with us (ID: 210).
    Unfortunately, this order has failed due to payment not being completed or due to a pending payment failing.
    If you would like to complete this order, please visit our client area again and click Place Order to place the order again.

    Yeah right...

    While paypal shows...that i did pay...and was succesful.
    so craigbrasssystems aren't flawless..;)

    so where's my license...??
  2. craigbrass

    craigbrass New Member

    I am very sorry about this - I noticed this last night when I got back home (our system logs all errors and emails them to us for debugging) and forwarded it to the developer who wrote the client area. He found it actually wasn't our systems at fault. PayPal's systems were sending out a 500 Internal Server Error when we tried to confirm the transaction (with PayPal, it sends you details of a transaction to your systems and you post this back to theirs to confirm the message was sent by them). There isn't much we can do about this other than manually process the order later. I personally have never seen it do this before, though.

    Either way, I will get your licence sorted this morning and sorry about the inconvenience. It will be flawless for future orders assuming PayPal keep their systems in order!
  3. mariow

    mariow Member

    thats fine, i dont know why it happens...
    but a simple check on your paypal account will verify it also.;)
  4. mariow

    mariow Member

    And 2 minutes ago again i received:

    You recently tried to placed an order with us (ID: 210).
    Unfortunately, this order has failed due to payment not being completed or due to a pending payment failing.
    If you would like to complete this order, please visit our client area again and click Place Order to place the order again.
  5. mariow

    mariow Member

    Hello Craig, what did you mean by..
    You haven't sorted out anything as its 6 hours later and still nothing.
    your from the u.k which means we only have a 1 hour difference timezone.
    I dont know why you blame paypal for this ,their system says i paid....so as far as i can tell your system messed up. i cant check your story,but paypal shows the details as they are.
  6. supportskins

    supportskins Kayako Guru

    Was the ticket delete functionality added in this release?
  7. mariow

    mariow Member

    Hello Craig, i dont know where you are but its disapointing to see that you dont keep your promises. you said you will fix it this morning, which was yesterday. i bought the license saturday evening 22:50 , and now its monday and still nothing. not even a reply from your own ticket system.
  8. craigbrass

    craigbrass New Member

    I do apologise. It was PayPal at fault. See https://www.paypaldeveloper.com/thread/42429?start=0&tstart=0 (ignore the SSL certificate - looks like somebody @ PayPal forgot to renew!).

    PayPal sends notifications to our systems to tell us when a payment has come through. We post this back to PayPal for verification. When posting back, PayPal was giving us a 500 Internal Server Error. This doesn't happen on their sandbox testing environment, only on the live system. This change appears to of only happened in the last week, too, and for certain types of payments.

    Yesterday was Easter Sunday. I pulled the developer in question away from what he was doing but he could only spare 30 minutes and wasn't able to fix it in that period so only started looking at it again this morning, when we found that post on the PayPal Developer Forums.

    We don't have a way of (easily) creating licences in the new system manually yet (something that is getting resolved today) so I needed to wait until our system was changed with a small "code hack" as detailed in the thread I linked to so I could then resend the payment notification from PayPal's systems and it then auto generate your licence.

    I am pleased to say your licence should now of been emailed to you and is available for viewing in our client area at https://www.craigbrasssystems.com/clientarea/

    Once again, I apologise for the delay. I can assure you that this was an isolated incident that we could not prevent (as that forum post mentions). I am sure the application will be well worth the wait, especially when you see version 2 combined with Kayako v4 :)
  9. craigbrass

    craigbrass New Member

    @Hiren: No, it does not. 1.0.7 will feature this functionality and is due out in the next month (mentioned in our previous post announcing 1.0.6).
  10. supportskins

    supportskins Kayako Guru

    Ah okay. Thanks for clearing that up.
  11. mariow

    mariow Member

    thanks craig, got the license and it works.
    thing i had a problem with is the waiting....you weren't online while you said to fix it in the morning....
    but i got it now and thats what matters...
    sure im just as curious to see what the next versions might bring..;)
  12. craiginsight

    craiginsight New Member

    Hi,

    I've downloaded the trial version but get "Error: Invalid Server Response. You may need to add Content Type Code".

    I've upgraded to the latest version of Kayako as suggested however, still get the error.

    Does anyone know how I can resolve this?

    Thanks,
    Craig
  13. Bashar

    Bashar Established Member

    same here getting "Error: Invalid Server Response. You may need to add Content Type Code" on my Bold 9700 testing the trial
  14. Bashar

    Bashar Established Member

    btw i did whats mentioned here Troubleshooting - Craig Brass Systems Forum and still getting the same error

    is it only /mobile/index.php or other files? because when i access it via the browser i get this error:
    compressed;4a5df112ba705a3a9f0f4abb0942820a;6bb61e3b7bce0931da574d19d1d82c88;10;2;x^�5����_

    both with or without ur code
  15. Marcel Trapman

    Marcel Trapman iOS Developer Staff Member

    That is not an error but the actual response of the server (probably carrying an error though because manual login of mobile is pretty tough).
    It only makes sense after decompressing the reply and decoding it.

    Concerning the original question, sorry I can not answer that but I am pretty sure Craig can :)
  16. craigbrass

    craigbrass New Member

    Hello Basher,

    Assuming you have done the second item listed at Troubleshooting - Craig Brass Systems Forum, please login to our Client Area and submit a ticket. If you could submit FTP access to your help desk and a Kayako administration area account, that will make it easier to debug.
  17. Jeton

    Jeton Member

    I have just instaled kayako on blackberry. But there is error when tring to connect. Error: Unable to connect.

    I can browse internet on browser but cant connect to kayako blackberry.

    What can i do?
  18. craigbrass

    craigbrass New Member

    Hello Jeton,

    There is a troubleshooting step listed at Troubleshooting - Craig Brass Systems Forum that should fix the issue. If not, please follow the steps at the bottom of that troubleshooting post to submit a ticket to us.
  19. Jeton

    Jeton Member


    Thanks Craig, its working.

    Now i have a problem with Purchaseing the product.

    When i want to pay by visa debit a have a other error listed below:

    Secure Payment Page

    Sorry, there was an error in processing this transaction: No payment information is available. This means that one of the following has occurred:
    • you have completed or cancelled your payment
    • you have cookies disabled. To complete your payment, enable cookies by changing the privacy settings in your browser. Then return to the merchant's site and resubmit your payment
    • your session at RBS WorldPay has timed out. Please return to the merchant's site and resubmit your payment

    Im using this card to pay for Kayako but in Your page can't.
  20. craigbrass

    craigbrass New Member

    Hello,

    I have ran a few tests and can't reproduce this. The only things I can think of is you actually have cookies disabled (or set to not accept cookies from certain sites) or RBS WorldPay was just having problems at the time. Can I ask you to try again?

    PayPal is also an alternative if you still can't get it to go through. You don't need an account these days, either.

    Best Regards,

Share This Page