1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

Can not create directory in tmp

Discussion in 'Technical chat' started by lolka_bolka, Nov 12, 2015.

  1. lolka_bolka

    lolka_bolka New Member

    Today I've made an upgrade to 4.71.2

    Yesterday I did it once, but there was an 505 error, so I've decided to delete everything, and create a new clean install.

    Deleted everything, and upload every file through FTP, set the config.php, and copy back the attachments.

    I've run the setup, it was fast and success.

    Then I rebuild the cache as in the documentation says, and deleted the setup directory.

    Now, when I want to reply to a ticket, I've got this message:

    Warning
    mkdir(): Operation not permitted (./__swift/thirdparty/SwiftMailer/classes/SwiftMailer/KeyCache/DiskKeyCache.php:279)

    I opened this file, and inserted this: var_dump($cacheDir);

    And here is the funny part. The cache direcotory is: string(37) "/tmp/129f487d17157ae756aa13635a955a7d"

    It's a debian box, and I've checked the tmp directory, it has permission 777 with t flag:

    drwxrwxrwt 3 root root 4096 Nov 12 09:17 tmp

    What could be the problem now? Why keycache file can not create a directory in a proper set tmp directory?
     
  2. Gary McGrath

    Gary McGrath Staff Member

    The chances are you have some kind of security block which prevents the app from accessing that folder, check you are not using openbase_dir or safe mode restrictions.

    Gary
     
  3. Muhammad Waqas

    Muhammad Waqas New Member

    whenever any ticket is replied i am getting the below error , I tried my level best to solve with this information yet i am failing

    Warning
    mkdir(): No such file or directory (./__swift/thirdparty/SwiftMailer/classes/SwiftMailer/KeyCache/DiskKeyCache.php:277)

    I performed following steps
    1 ) Check Email Parser > Email Queue > open the Mail account > verify Account it gives all green checks
    2) i went to cpanel > file manager > updated the file permission > 755 >
    3) updated folder permission
    4) Access WHM > Security Center > PHP open_basedir Tweak >uncheck the option > PHP open_basedir security will be disabled for all domains.
    5) check safemode option as well

    still my problem is same
     
  4. Muhammad Waqas

    Muhammad Waqas New Member

    I check /tmp and found to be (700) I updated it to (777)

    It is hosted on my own server with full WHM and root access


    Things I attempted

    I uncheck the open_basedir as well , as per the google search , snapshot attached

    diskusage space is not above 50% - Snapshot attached

    I give the same permission to KeyCache folder to ( 755) and DiskKeyCache to (755) as well

    I also cross check mail queue - snapshot attached
     

    Attached Files:

Share This Page