1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

code 421 4.4.2 Message submission rate for this client has configure the configured limit

Discussion in 'Technical chat' started by Remi Ketoma, May 12, 2016.

  1. Remi Ketoma

    Remi Ketoma New Member

    Hi guys,

    wondering if anyone can enlighten me on this error:

    Expected response code 250 but got code "421", with message "421 4.4.2 Message submission rate for this client has exceeded the configured limit

    A staff gets this whenever he wants to bulk update (close) tickets.

    Was of the opinion there was a limit on the mail account used by kayako however, the ms exchange guy says there's no limit.

    I've checked under settings>Email settings to find where i might increase this "message submission rate" but can't see anything related.

    IS this error popping up because of an incorrect setting on the application server or on the exchange server?

    Anybody with some idea, please help.

    Thanks.

    Remi.
     
  2. Phil R

    Phil R Established Member

    That error is categorically an MS Exchange error.

    Despite the check, there is certainly further investigation required.

    For this specific error, there is a limit. It's not possible to disable the limit, only set it very high.
     
  3. matt.hunt

    matt.hunt New Member

    We had the same error except our exchange server submission rate was set to unlimited.

    We simply set the "Use an SMTP server to send email" to No. Kayako will then use PHP_mail() instead of SWIFT to send emails. You'll also have to configure your php.ini file to use PHP_mail():

    [mail function]
    ; For Win32 only.
    ; http://php.net/smtp
    SMTP = mail.mycompant.com
    ; http://php.net/smtp-port
    smtp_port = 25

    ; For Win32 only.
    ; http://php.net/sendmail-from
    sendmail_from = kayako@email.com

    ; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
    ; http://php.net/sendmail-path
    sendmail_path = "C:\sendmail\sendmail.exe -t"

    If you are like us and are running Kayako on Windows Server then you will need to download and configure sendmail in order to pass authenication. http://glob.com.au/sendmail/

    Once we started using PHP_mail() the error stopped occurring :)
     

Share This Page