1. The forum you are viewing relates to Kayako 3, which reached end of life in 2012. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (i.e. plain wrong!).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

Configure PHP.INI settings for a Windows based server

Discussion in 'Installation and upgrading' started by netFusion, Jul 20, 2005.

  1. netFusion

    netFusion Reputed Member

    Here are some things you can check in your PHP.INI file if you are having trouble with PHP scripts.

    The following settings are from a working installation and have been tested under both Windows 2000 and Windows 2003 using both CGI and ISAPI setup.

    Code:
    safe_mode = Off                ;not everything works with safe mode
    max_execution_time = 300       ; Maximum execution time of each script, in seconds
    max_input_time = 120	       ; Maximum amount of time each script may spend parsing request data
    memory_limit = 8M              ; Maximum amount of memory a script may consume (8MB)
    
    error_reporting  =  E_ALL & ~E_NOTICE       ;Normal operating mode.  Set to E_ALL if you need to debug
    display_errors = OFF           ;Normal operating mode.  Set to ON only if you need to debug.
    display_startup_errors = OFF   ;Normal operating mode.  Set to ON only if you need to debug.
    log_errors = On
    error_log = C:\TEMP\PHP.LOG    ;I write errors to a log file. This file MUST be in a folder writeable from all websites.
    
    post_max_size = 32M            ;Max size of messages and files that can be posted by PHP in Meg.
    
    extension_dir = "C:\PHP"       ;Assuming you have copied your extensions into C:\PHP like I told you to
    cgi.force_redirect = 0         ;Must be turned off for IIS.
    
    file_uploads = On              ;If you want users to be able to upload files using PHP scripts.
    upload_tmp_dir = "C:\TEMP"     ;Path must be in a folder writeable from all websites.
    upload_max_filesize = 32M      ;Max file size that can be uploaded.
    
    
    register_globals = On
    
    session.bug_compat_42 = 1
    session.gc_probability = 1
    session.gc_divisor = 100
    session.gc_maxlifetime = 1440
    session.save_path = c:\temp      ;note this path will be different if you are on a linux box
    session.bug_compat_warn = 1
    
    session.save_handler = files
    session.use_cookies = 1
    session.name = PHPSESSID
    session.auto_start = 0
    session.cookie_lifetime = 0
    session.cookie_path = /
    session.cookie_domain =
    session.serialize_handler = php
    
    session.referer_check =
    session.entropy_length = 0
    session.entropy_file =
    session.cache_limiter = nocache
    session.cache_expire = 180
    session.use_trans_sid = 0
    
    
     
  2. TheDoctor

    TheDoctor Established Member

    Made sticky as well :)

    Only comment I had was whether register_globals needs to be on for V3 as Im sure i've not got it set to on at the moment on my 2003 server, but only going by memory at the moment as I'm not near the server to check.

    Regards
    Alan
     
  3. kickarse

    kickarse New Member

    That is truly helpful, thanks!
     
  4. netFusion

    netFusion Reputed Member

    You may be correct. Looking through the code, there are comments in there that suggest you may not need register_globals with v3. I have not tried it yet to see what happens.

    Eddie
     
  5. Varun Shoor

    Varun Shoor Chief Kayaker Staff Member

    Hi,
    v3 does not require register globals to be enabled.

    Regards,

    Varun Shoor
     
  6. dcohn

    dcohn New Member

    all things being equla what is the "BETTER MORE STABLE" Platform to run PHP/Kayako on. I constantly here Linux from many people but then I hear that it runs fantastic in W2K3.

    Which is it.
     
  7. Varun Shoor

    Varun Shoor Chief Kayaker Staff Member

    We prefer Linux but have received no complaints from our Windows users. All of our products have been developed keeping the different operating systems and browsers in mind.

    Regards,

    Varun Shoor
     
  8. Shawn

    Shawn New Member

    I hope im posting this in the correct place. I am currently trying to get my pop3/imap Setup on a windows 2000 server. When i go to the php.ini and uncomment the "extension=php_imap.dll" everything quits responding. as well as support site, staff site, and the admin site. I have it currently commented out and the site works fine. What am i doing wrong. None of my email for anything currently works having to do with Kayako.
    Any help appreciated.
    Current Config looks like the following.
    http://www.milestonemortgage.com/support/phpinfo.php
    My sql version is "5"
    Thanks in advance.
     
  9. netFusion

    netFusion Reputed Member


    Hi Shawn!

    First things first.

    Did you follow my instructions here: http://forums.kayako.com/showthread.php?t=4066

    If so, and if you have your PHP.INI file setup as in the first thread above, you should have a file in your C:\TEMP\ folder called PHP.LOG.

    Enable the "extension=php_imap.dll", restart IIS, access your support suite page so it will load PHP. Then open up the C:\TEMP\PHP.LOG file in notepad and look for any errors.

    My first guess is that you do not have the php_imap.dll in the same folder as your PHP.EXE file or you do not have the C:\PHP\ folder in your system path. Thus PHP errors out when it can not find the extension to load.

    Second guess would be that the user your web site runs under might not have the correct permissions to your C:\PHP\ folder.

    Post your findings from the php.log file when you get a chance.

    As for running SupportSuite on MySQL 5 under Windows, I could not tell you. I'm still running it on 4.x.

    Eddie
     
  10. ehoffman

    ehoffman New Member

    I use Win2k3 and its great. Just be careful with PHP setup.

    MySQL 5....yes there are issues. You need to pull it out of strict mode in your instance configuration or you will have some very funky things going on. We did that and its a lot better.
     
  11. KPotter

    KPotter New Member

    I tried for months to get version 3 working with PHP5 on IIS 6.0. I would always get a blank setup page, even though a test .php page was working fine. Hiren suggested changing the following values which finally got me up and running:

    short_open_tag = On
    max_execution_time = 600
    magic_quotes_gpc = On
     
  12. danielpugh

    danielpugh New Member

    emphasis

    magic_quotes_gpc = on
    just spent 3 weeks trying to work out why kayako was slow over vpn(could manually telnet to port 80 and enter get / http/1.1 etc with unexplained 20 sec delay) above fixed the problem.

    one other thing that may have helped is output_buffering=on

    should mention that the slowness was mainly evident on osx/mac (virtual machine running windows on the mac in vmware fusion did not have the problem)
     
  13. Casey Rousseau

    Casey Rousseau New Member

    extension=php_mcrypt.dll
    Must be enabled for 3.30.00 and later.
     
  14. Susan

    Susan New Member

    mCrypt not enabled


    We really need some help getting mCrypt enabled prior to an upgrade. I have tried everything suggested on the PHP site - everything suggested in this forum - and everything suggested in other forums and it just won't enable.

    PHP=5.2.5 on Windows 2003 server with IIS6 ISAPI

    Any help with getting this up and running would be appreciated.
    Thanks,
     
  15. Mathiau

    Mathiau Member

    from mmentegy

    register_globals = On


    thats a big no no,opens a large security gap if your not very very careful with your coding.,
     

Share This Page