1. This sub-forum relates to Kayako 3, which is now end-of-life. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (no longer applicable).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

Disabling comments and stopping comment spam in Kayako 3

Discussion in 'Customizing, extending and styling Kayako 3' started by bear, Mar 4, 2007.

  1. bear

    bear Reputed Member

    Since no one was able to provide the steps to disabling comments to avoid spammers, I've done so. This guide will only remove it entirely, not just allow it for logged in users, so bear that in mind. To allow only logged in users, you could probably use an IF statement to show only if logged in, but this was all I needed so I stopped there. ;)

    To remove the ability for visitors to use comments completely:
    Go to the admin area of your Kayako install and look under the left menu for "templates" and expand it.
    Under that menu, look for "search templates".
    Search for "comments".
    This should return the following templates:
    comments #3
    tsstepdisplay
    nwitemnavbar
    nwviewnews
    nwlistdisplay
    dlviewdownload
    dlitemnavbar
    kbarticlenavbar #2
    kbarticleview #1

    To disable the showing of the comments option in the main KB article view, edit #1, removing this part near the bottom:
    Code:
    <{displaytemplate name="comments"}>
    To disable the comment option under "Article options" in the right hand menu, edit #2, place comments around (or remove) the following (comments are < ! -- and -- > (spaces added):
    Code:
    <div class="navitem" onMouseOver="javascript:this.className='navitemhover';" onMouseOut="javascript:this.className='navitem';"><img src="<{$themepath}>icon_addcomment.gif" width="16" height="16">&nbsp;<a href="#" onClick="javascript:switchDisplay('comments');"><{$language[addcomment]}></a></div>
    .

    To prevent direct submission of comments, edit #3, changing or removing the following form action from the top:
    Code:
    "<{$basepath}>"
    Make sure you include at least an empty pair of quotes "" for the action, and direct submissions should go nowhere.

    Editing #3 removes all abilities to allow comments, so use with caution. To edit out the other areas (news and downloads), just see the various other templates listed above and edit accordingly. Hope this helps clear up the mystery surrounding removing comment spam for good. No one seemed to be willing to explain this, so I took the time to write it up.
     
  2. beHosting

    beHosting New Member

    Thank you! I had done #1 and #2 and removed all references to the comments links from all templates, but somehow they were still managing to spam the knowledgebase comments to the tune of hundreds per day.... #3will keep it from happening.

    Thanks again!
     
  3. datasolution

    datasolution New Member

    <removed quoted post>

    Nice tips... But can u tell how I can I disable in PHPBB forums... which is I used..?

    Or If you have any resouce which I can use to disable...

    thanx
     
  4. bear

    bear Reputed Member

    I have no idea. This is a forum for Kayako, and I posted a tip about that product. Have you tried the PHPBB author's forums?

    @BeHosting: You're welcome. ;)
     
  5. bcarpenter

    bcarpenter New Member

    Thanks Bear for the great how-to. I sure appreciate you taking the time to do this.

    Brian
     
  6. ansuk

    ansuk New Member

    Fantastic, thank you :D
     
  7. jj1987

    jj1987 New Member

    Thanks for this! I just implemented it and it works great.
     
  8. Matthew

    Matthew Reputed Member

    Another thanks here!

    I use different template groups for guests vs registered users, so this works great for disabling comments from 'guest' spammers.
     
  9. Raid

    Raid Member

    Hi,

    i doesnt work for me, i controlled it 3 times an i have all changes maked like here described.

    if you go on the site you have no chance to make a comment, all ist deleted.

    every day we must delete in the staff panel 4000 spams from gmail like now778@gmail.com or now489@gmail.com an that sucks.

    with your hack our clients doesnt see the spam and NEW spam bots have no chance, thats one advantage but im searching a solution, that the spammer cant post from the outside. i think the spammers maked a copy from the comments-form an know they spam with this one from the outside.

    i hope that eSupport 3.20.03 with captcha will stop the spambots but i installed alreday the captcha mod but i doenst work for the gmail spam. :(
     
  10. craigbrass

    craigbrass New Member

    Raid: This will hide it. You should just ignore any spams inside the staff control panel as your customers will not see them.
     
  11. bear

    bear Reputed Member

    Including this one?
    "To prevent direct submission of comments, edit #3, changing or removing the following form action from the top:"
    That should make it impossible to submit to that page. There should be no chance of external submission to your desk, and if there is, there's a bigger problem.
    You need to trace where they are submitting from and block access to your server from there, as well as determining how they can submit this externally, if that's the case.
     
  12. Raid

    Raid Member

    ... please look at the attachmend, if it is right.



    ... we've tried it with iptables to block access but it is every day a new ip.

    what i dont understand, whats going on here? i looked after the spam comments and the time and then i searched the logfiles after the client you maked the spam:

    83.222.23.235 - - [18/Apr/2008:10:20:53 +0200] "POST /index.php HTTP/1.1" 302 - "http://google.com" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
    83.222.23.235 - - [18/Apr/2008:10:20:18 +0200] "POST /index.php HTTP/1.1" 302 - "http://google.com" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
    83.222.23.238 - - [18/Apr/2008:07:24:13 +0200] "POST /index.php HTTP/1.1" 302 - "http://google.com" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"
    83.222.23.238 - - [18/Apr/2008:07:24:40 +0200] "POST /index.php HTTP/1.1" 302 - "http://google.com" "Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)"


    All IPs are registered to a lot of Data Centers in Moscow, and i think to make an Abuse Message is how we said in Germany "a drop on a hot stone". Somebody will make an Abuse Message an in the next hours they have a new Server ...

    I have no idea where is the bug in eSupport that they can post their spam.
     

    Attached Files:

  13. jnet

    jnet New Member

    whenever there is a problem we should find a solution why disabling it?
    Kayako should find a way to stop or atleast decrease the spam
    comments is good.

    well any way my comments don't work at all in said that in another thread and still did not get any solution:mad:
     

Share This Page