1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

  2. The forum you are viewing relates to Kayako Classic. If you signed up or upgraded to the new Kayako (after the 4th July 2016), the information in this thread may not apply to you. You can visit the forums for the new Kayako here.

Email parser missing some mail collecting from Office365 mailbox

Discussion in 'Using Kayako Classic' started by Martin Smith, Jun 19, 2012.

  1. Martin Smith

    Martin Smith New Member

    We have the email parser set up to collect mail from an Office365 mailbox using a fetch type of IMAP SSL and Leave Copy on Server set to Yes. It works 99.99% of the time but occasionally it misses one the emails in the mailbox. When I say misses I mean that the there are no log entries for that piece of mail and mail before and after it are processed correctly.

    The team don't entirely trust that all emails are getting into Resolve so when they find one like this it reinforces their fears. Any help much appreciated
     
  2. Matthew Dunne

    Matthew Dunne New Member

    We have the same problem, but with import from GMail.
     
  3. Gary McGrath

    Gary McGrath Staff Member

    Hi Matthew,

    What are the characteristics of the email that was not collected, size, attachements etc...

    Also, in admin CP, mail parser, settings, what do you have "Maximum Number of Messages To Process In Single Pass" set to?

    Gary
     
  4. Matthew Dunne

    Matthew Dunne New Member

    Hi,

    The emails are just basic emails from our contact form so just text / html, they are the standard email that it processes 90% of the time, there is nothing that stands out as odd about the ones that it missed.

    In regards the Maximum Number of Messages To Process In Single Pass that is set to 10, could this be the issue? However if it hits 10 would it then not pickup the 11th message next time etc?

    Thanks for your reply,
    Matthew
     
  5. Gary McGrath

    Gary McGrath Staff Member

    Hi Matthew,

    If the emails have the same arrival time, It can cause an issue, due to the way IMAP syncs actually work, I would recommend upping it to cover "the amount of emails that usually arrive within the time between syncs", a good 40+ would be ok

    Gary
     
  6. Matthew Dunne

    Matthew Dunne New Member

    Thanks,

    Ill try this and monitor it over the next few weeks.

    Thanks for the help,
    Matthew
     
  7. Szentmarjay Tibor

    Szentmarjay Tibor Established Member

    Another solution could be to forward the emails to a separate mailbox where you don't have to leave the "Leave Copy on Server" on. For me this caused with other applications several times issues.
     
  8. brat42

    brat42 Established Member

    Sorry to reignite this thread but did you guys manage to solve some mail NOT going through for IMAP with Office 365?

    We have just switched from Google which worked perfectly, and I'm starting to worry, as POP does not work at all with Office 365 [repeatedly parses the same email].

    I am increasing from 10 to 30 on "Maximum number of emails to download in a batch" but this is my last resort.

    I find that if an email has not come into Kayako, marking the email as "unread" does finally bring it in.
     

Share This Page