Errors Generating/Accessing Reports

Discussion in 'Technical chat' started by jonbeard, May 1, 2012.

  1. jonbeard

    jonbeard New Member

    Hello, we use Kayako's support desk, however every time we generate a report or try clicking on a report we get the following error:

    Code:
    [User Error]: #0 /home/support/public_html/__swift/library/KQL/class.SWIFT_KQLSchema.php(115): SWIFT_Module::RetrieveKQLSchemaObject('ticketlist')
    #1 /home/support/public_html/__modules/reports/staff/class.View_Report.php(528): SWIFT_KQLSchema::GetCombinedSchema()
    #2 /home/support/public_html/__modules/reports/staff/class.Controller_Report.php(297): View_Report->RenderGrid(1107)
    #3 [internal function]: Controller_Report->Manage('1107')
    #4 /home/support/public_html/__swift/library/Loader/class.SWIFT_Loader.php(115): call_user_func_array(Array, Array)
    #5 /home/support/public_html/__modules/reports/staff/class.Controller_Report.php(258): SWIFT_Loader->__call('Manage', Array)
    #6 /home/support/public_html/__modules/reports/staff/class.Controller_Report.php(258): SWIFT_Loader->Manage('1107')
    #7 [internal function]: Controller_Report->QuickFilter('category', '7')
    #8 /home/support/public_html/__swift/library/MVC/class.SWIFT_Controller.php(336): call_user_func_array(Array, Array)
    #9 /home/support/public_html/__swift/library/Module/class.SWIFT_Module.php(164): SWIFT_Controller::Load(Object(SWIFT_Interface), Object(SWIFT_Module), Object(SWIFT_Router), false)
    #10 /home/support/public_html/__swift/library/class.SWIFT.php(765): SWIFT_Module->ExecuteController()
    #11 /home/support/public_html/__swift/library/class.SWIFT.php(919): SWIFT->Initialize()
    #12 /home/support/public_html/__swift/swift.php(154): SWIFT::GetInstance()
    #13 /home/support/public_html/staff/index.php(28): require_once('/home/support/p...')
    #14 {main}
    Invalid data provided (library/class.SWIFT.php:768)
    Does anyone have any ideas how to fix this? I have tried searching around, but with no prevail :-(

    Thanks in advance gang!
     
  2. hanel

    hanel New Member

    I've just noticed that I'm getting exactly the same error. I receive this error as soon as I click on the Manage Reports button or try to create a new report. The only section I can now get into under the Reports tab is the Categories section.

    I believe this has only happened since upgrading to the version 4.40.1079. I have been using the reports before this and have modified and created a few of my own reports.

    Any help would be appreciated.
     
  3. Ashok Makahija

    Ashok Makahija New Member

    To fix the issue, you need to perform the following steps:

    1. Delete/Move third party module directory from '__module' folder of helpdesk installation.
    2. Run the following query in help desk's database:

    SELECT * FROM swsettings WHERE section = 'registeredmodules'

    It will display all the registered modules and you need to delete all the third party modules entries from the Kayako database.

    3. Replace the attached file (class.SWIFT_SetupDatabase_reports.php) under "__modules/reports/config/" folder.
    4. 'Force Upgrade' reports module from : Admin CP > Module > Reports > Force Upgrade.
    5. Once done, please revert the file and cross-check sample reports under Staff CP > Reports > Manage Reports.

    Please make sure that you run Force Upgrade only once.
     

    Attached Files:

Share This Page