1. The forum you are viewing relates to Kayako 3, which reached end of life in 2012. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (i.e. plain wrong!).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

Help: Email loop won't stop!

Discussion in 'Kayako 3 Forums' started by sqzdog, Dec 7, 2007.

  1. sqzdog

    sqzdog Established Member

    I manually added a new member last night. My system sends them an email with a temporary password. (out of the box, not modified at all)

    Afterwards, I started getting these messages about every minute. Coming up on 24 hours now and I can't figure out why and how to stop it.



     
  2. internut33

    internut33 New Member

    Surprised flood protection did not stop this. I had this issue when i first used the software and not sure if this check was in.

    Trying to remember how i stopped it.

    Maybe take down the mail parser / cron & check the pop e-mail box and delete the e-mail that comes in that keeps looping.

    I'm probably way off just thought i'd try and give an answer before you get an official or better one.
     
  3. supportskins

    supportskins Kayako Guru

    Temporary disable your email piping, clear your server maillog matching the from address and it should stop sending emails.
     
  4. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    Hi sqzdog,

    In your mail parser rule for this, add a condition for "Flood protection triggered" - then decide what you wish to do (i.e. ignore the e-mail completely (risky), not auto-respond to it) and so on.
     
  5. sqzdog

    sqzdog Established Member

    Where do I disable the email piping? Also, I guess I will need to contact my hosting company about the maillog. I don't think I have access to that unless it is in cpanel somewhere.

    Jamie- I want to be able to have the system stop mailing the client every minute. I have blocked it on my end just by sending it to spam. But a week later, they are still getting emails from my server.
     
  6. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    Hi sqzdog,

    You will have to purge the mail queue in order to stop them being sent out. You can disable e-mail piping either by removing your forwarding aliases or deleting your e-mail queues.
     
  7. sqzdog

    sqzdog Established Member

    So if I go into my forwarder in cpanel and disable that temporarily, that could fix it?
     
  8. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    That won't stop e-mails leaving your server that are already in your outgoing queue (the server's queue - not Supportsuites), but if an e-mail loop is currently in progress then this would stop the loop spiraling further.
     
  9. sqzdog

    sqzdog Established Member

    My host said that I needed to turn my "auto reply" off first then he can dump the outgoing email queue. Is he referring to the forwarder?
     
  10. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    No, your is referring to the auto responder you have enabled for your e-mail queue (i.e. the ticket receipt issue e-mail).
     
  11. supportskins

    supportskins Kayako Guru

    As I said, disable email piping for a while. Clear your maillog on your server and it should fix the issue.
     
  12. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    Do you mean the e-mail queue (that queues e-mails to be sent out), or the log (records of mail actions)?
     
  13. supportskins

    supportskins Kayako Guru

    The issue here is that the email queue is set to accept email only from Registered Users. Since the email queue is yet accepting email the loop persist. If you disable email piping the loop will stop allowing you to clear your server maillog. Once the maillog is cleared you can re-enable email piping. That should get things back to normalcy.
     
  14. sqzdog

    sqzdog Established Member

    Ok, I will ask again; How do I disable email piping?
     
  15. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

     
  16. sqzdog

    sqzdog Established Member

    Follow up: This is fixed, but wanted to update those that helped me what I did to stop this.

    When I set up my support suite originally, I had set up an email address (support@mysite.com), then forwarded all those emails to my main email address. I didn't realize that I could add an email forwarder without actually creating that account. I deleted the account, left the forwarder in place and it fixed the problem.

    Thanks for all of the support that I received on this problem
     

Share This Page