1. This sub-forum relates to Kayako 3, which is now end-of-life. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (no longer applicable).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

Howto disable the auto responder

Discussion in 'Kayako 3 Forums' started by Marc, May 9, 2006.

  1. Marc

    Marc New Member

    Hello,

    how can i disable the autoresponder feature. Everytime a new ticket is created or a mail is sent directly to the ticket system there is a auto response mail gernerated like this:

    "Your ticket has been received, one of the staff members will review it and reply accordingly. Listed below are details of this ticket, Please make sure the Ticket ID remains in the subject at all times."

    We don't want this mail to be sent out, how can we disable it?

    Thank you for help
  2. Acoustica

    Acoustica New Member

    In the admin area, select Mail Parser > Manage Email Queues, and each email queue will have its own autoresponder settings.
  3. Marc

    Marc New Member

    I see, but it won't work.

    The Queue is active and used by incoming emails. I can see it by the "Queue Subject Prefix".

    "Enable New Issue Autoresponder?" is set to "No"
    "Enable New Reply Autoresponder?" is set to "No"

    but anyhow the Auto Responder mails are sent out. Is it a bug?
  4. Neil-UKWSD

    Neil-UKWSD Kayako Guru

    Hi,

    This is a bug and on the list to be fixed.
  5. Marc

    Marc New Member

    Dear Neil,

    thank you for the answer. Then i expect the bug to be fixed in around 2 years. I already commited another small, but for us serious bug in the bug system half a year ago and nothing happened.

    It is really a pity that such basic functions are not working and that such simple bugfixes take so long.
  6. xian

    xian New Member

    Ug. I started paying for this software thinking that options in the software would actually work.

    How long will I have to wait for:
    Outbound smtp.
    Autoresponders off.
    No ticket # in the subject.

    Its like a $40/month beta test. Totally unusable until these issues are dealt with. Sounds like it could be a while.
  7. xian

    xian New Member

    Outbound mail is working now thanks to support!

    But is there a way to see the status of the auto-responder bug? Is there a way to see what bugs are alive/being worked on?
  8. Marc

    Marc New Member

    You can see the status at the bugs system at http://bugs.kayako.net, but i cannot find this bug here.

    The strange thing is, yesterday we updated to v.80, after the update we had this bug, before in the old version the auto responder was turned off successfully.

    Anybody else out there with the same problem or can anybod turn of the auto responder successfully?
  9. Neil-UKWSD

    Neil-UKWSD Kayako Guru

    Hi,

    The bug is not listed in the bug tracker as it has been added directly to the post .80 fixes list for the .81 build.
  10. Marc

    Marc New Member

    ok, when will the .81 build be available?
  11. bdwyer

    bdwyer New Member

    There's no simple code modification to disable ALL autoresponders?
  12. Extra

    Extra Established Member

    This bug critically needs an interim update.

    In an email to ticket system, undetected spam comes in, auto-response goes out.

    WE then become the "spammer"

    Please post a code fix to disable the autoresponder globally until the .81 is released.

    Thanks.
  13. xian

    xian New Member

    To disable auto-responders:

    Admin CP -> Mail Parser -> Insert New Rule:

    Criteria: Destination Email Contains helpdesk@yourcompany.com

    Don't Send Autoresponder Message: yes!

    That should do it, give it a shot.
  14. Extra

    Extra Established Member

    Hello Xian,

    Thanks for the help.

    Master is set to no auto-r's each pre-parse is set to no A-responders. Problem is there is a bug in .80 where you cannot turn them off in either mail rules or master settings.

    Is a known issue and correction is in .81 BUT until then we are spammers....

    Thanks,
  15. xian

    xian New Member

    I was experiencing the same bug, but the destination email Rule worked for me.. sorry you dont have the same luck.
  16. Extra

    Extra Established Member

    Hi Xian,

    Thanks for the help. We have 67 email queues with both pre and post parse rules. Each is set to no auto responder in in the preparse rules.

    It appears that each is sending auto-responses (but I have not tested each.) I have only tested the ones we see returns from.

    Niel indicated a correction to a known bug. Our concern is the number of auto-responses going out to undetected spam that gets into the ticket syste and then we auto respond as though we are the spammer :)

    Again thanks for trying to help.

    ET
  17. xian

    xian New Member

    Are you using fetch? I am having trouble with the ticket numbers being displayed in the subject - that seems to also be a bug, however when I used the Kayako Demo, there was no problem removing the ID from the subject.

    I am trying to get kayako to generate a new key for me to run SupportSuite on my production mail server so I can pipe. They havent answered my question regarding how they are doing it. I do know that my demo server was running SSHd - so its POSIX at least. Thats a good sign for me.

    Maybe I should try the .80 CVS ?

    Any advice?
  18. Extra

    Extra Established Member

    Hello Xian,

    Yes I would recommend the .80 CVS as has corrections in it and is very stable for us in a Linux environment. BUT, if you are in a windows server environment I cannot advise as we are in a cPanel/Apache Linux environment. We started in a Windows environment and realized the majority of issues were related to Windows compability, so we dedicated a Linux Dual Xeon to host SupportSuite.

    we have as of today processed over 80000 tickets through the system and nearly 5000 chats without major issues. (Just little nits like the auto responder.)

    Also side note. Our mail server is on a windows 2003 with Mailenable Enterprise. Mailenable receives the email and forwards to the pipe of SupportSuite that is on the Linux box. We use a forwarder built into cPanel to the assigned queue on SupportSuite. Works well with 2 seperate disparate boxes.

    Hope this helps.

    ET
  19. Marc

    Marc New Member

    The solution Xian proposed does NOT work here, auto responder emails are still sent out.

    We don't want to update to a CVS build because after every update we have to customize the system again, a lot of work. To much to do updates all the time.

    Because we cannot wait for Kayaka we have made a hotfix ourself.

    in file

    in Line 480 before if ($sendautoresponder && !empty($email)) we entered:

    For now this seems to disable the auto responder. If you test it please give feedback.
  20. Extra

    Extra Established Member

    Thanks Marc!

    Implemented and appears to be working well.

    We modified line 480 to be:

Share This Page