HTTP 500.0 - Internal Server Error

Discussion in 'Installation, setup, upgrading and importing' started by Kipetcoff, Aug 17, 2012.

  1. Kipetcoff

    Kipetcoff Member

    Hi, all. I need help.
    I try to install Kayako on Server 2008 r2 x64.

    I installed the PHP, has configured the database MySQL. I created an application in IIS, and gave all super rights to the Kayako application folder and C:\php folder, copy Kayako application folder, put the key.php there too, but nothing works, not the root directory, not \setup. Error HTTP 500.0 - Internal Server Error

    What should I do?

    [​IMG]

    [​IMG]

    Attached Files:

  2. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Hi there,

    Lets not worry about kayako right now, as a 500 server error basically means your php processor crashed on the server, so something is not configured right

    Can you create just a simple phpinfo page on the server, and see if that displays ok or if that also gets a 500 error?

    Gary
  3. Kipetcoff

    Kipetcoff Member

    [​IMG]

    Attached Files:

  4. Kipetcoff

    Kipetcoff Member

  5. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Hi there,

    Can you upload a copy of your php.ini I can look at?

    Gary
  6. Kipetcoff

    Kipetcoff Member

    this one. renamed

    Attached Files:

    • php.txt
      File size:
      69.6 KB
      Views:
      9
  7. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Hi there,

    Try the version of the file I have attached.

    Also, check check that IIS_IUSR user has full control of c:\windows\temp, c:\php and c:\inetpub

    ( note that IUSR is a different username to IIS_USR, you need the IIS one )

    Gary

    Attached Files:

    • php.txt
      File size:
      69.5 KB
      Views:
      13
  8. Kipetcoff

    Kipetcoff Member

    It did not help(( I put a file and check permissions.
    [​IMG]

    Attached Files:

  9. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    I think the issue your getting is probably down to one of the extensions, basically when the kayako setup tries to run, it loads various modules which the phpinfo does not, as soon as php is trying to load them, your getting the fastcgi crashing out.

    did you make sure to download the Windows VC9 (Non-TS) (x86) version of Ioncube loader?

    Gary
  10. Kipetcoff

    Kipetcoff Member

    ioncube_loaders_win_nonts_vc9_x86_ipf
  11. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Hi there,

    Ok, I have setup windows 2008 R2 with php 5.3 and ensured its working, I have then backed up the php directory into a zip file

    Make a copy of your php.ini, and then restore the linked file here over the top of your current php directory, so it replaces the files. Then copy back in your php.ini and see if that gets it running stable for you.

    php 5.3 zipped file

    Gary
  12. Kipetcoff

    Kipetcoff Member

    No results. Is it possible to help us tomorrow throw Team Viewer?
  13. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Hi there,

    I can certainly take a look for you tomorrow, can you pm me the connection detials? I will start the pm convo with you.

    Gary
  14. Kipetcoff

    Kipetcoff Member

    What time do you prefer? What time zone?
  15. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Ideally 1pm - 4pm BST

    Gary
  16. Kipetcoff

    Kipetcoff Member

    So now is this perfect time? Can we meet in skype? nikname kipetcoff
  17. Kipetcoff

    Kipetcoff Member

    I found some interesting errors in log.

    [20-Aug-2012 07:53:18] PHP Warning: require_once(./__swift/config/config.php): failed to open stream: No such file or directory in C:\inetpub\wwwroot\Kayako\__swift\library\class.SWIFT.php on line 16
    [20-Aug-2012 07:53:18] PHP Fatal error: require_once(): Failed opening required './__swift/config/config.php' (include_path='.;C:\php\pear') in C:\inetpub\wwwroot\Kayako\__swift\library\class.SWIFT.php on line 16
  18. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Hi there,

    if you goto __swift/config/ folder, there will be a config.new file, you need to rename this to config.php and then edit it and configure it with the settings for your mysql server

    gary
  19. Kipetcoff

    Kipetcoff Member

    I solve the problem. There was no file __swift/config/config.php. I followed all of the instructions in "Install Fusion on Windows 2008 R2 SP1 64 bit", but there was no information about config.php and other tricky features. Too poor instruction in my opinion.

    Attached Files:

  20. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

Share This Page