1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

  2. The forum you are viewing relates to Kayako Classic. If you signed up or upgraded to the new Kayako (after the 4th July 2016), the information in this thread may not apply to you. You can visit the forums for the new Kayako here.

HTTP Error 500

Discussion in 'Installation and setup (Kayako Classic Download)' started by MooFz, Sep 18, 2018.

  1. MooFz

    MooFz Member

    Hi,

    I'm trying to do a new install of Kayako Case on a new Centos7 server, but when I try to connect to kayako I get an HTTP 500 error.

    Ive followed the Installation Guide and set all file permissions as required.

    Any idea what I'm doing wrong?

    Thanks in advance!

    Attached is the /var/log/httpd/error_log:
     

    Attached Files:

  2. bear

    bear Kayako Guru

    Did you actually read the logs? That generally explains things, and in yours there's loads of "fopen ... permission denied". Start there.
     
  3. MooFz

    MooFz Member

    Bear thanks for your reply.

    The mentioned directory "/var/www/html/__swift/" has been recursivley chmod'd to 777, so it should have permissions, no?
     
  4. bear

    bear Kayako Guru

    That's a very bad idea, that recursive 777 permission. You need to put that back the way it was, since you just opened that entire directory to the world, basically.
    The permissions are likely related to the ability to "fopen" (file open). Though it can sometimes be caused by bad file permissions or missing files, it's also a setting that's some times disabled in PHP. Check with your provider if it's allowed on your server.
     
  5. MooFz

    MooFz Member

    Bear,

    I set the file permissions to 777 as they said in the installation guide.
    Oh I missread, __swift/library hasnt been chmod'd to 777, only __swift/files, __swift/cache, __swift/geoip, __swift/logs.

    In the php.ini "Allow_url_fopen" is set to "On".
     
  6. bear

    bear Kayako Guru

    What did Kayako support say when you asked them?
     
  7. MooFz

    MooFz Member

    They are also still looking into it.
    The first error was that php-Mcrypt wasnt enabled, which it is now.

    These are the new errors:
    Warning: fopen(./__swift/logs/log.error_18_Sep_2018_edf41e9c47.txt): failed to open stream: Permission denied in/var/www/html/__swift/library/Log/class.SWIFT_Log.phpon line414

    Fatal error: Call to a member function Assign() on a non-object in/var/www/html/__swift/includes/functions.phpon line188

    Warning: fopen(./__swift/logs/log.error_18_Sep_2018_edf41e9c47.txt): failed to open stream: Permission denied in/var/www/html/__swift/library/Log/class.SWIFT_Log.phpon line414

    Fatal error: Uncaught exception 'SWIFT_Exception' with message 'Invalid data provided' in /var/www/html/__swift/library/Log/class.SWIFT_Log.php:538 Stack trace: #0 /var/www/html/__swift/library/Exception/class.SWIFT_Exception.php(267): SWIFT_Log->Log('Warning??fopen(...') #1 /var/www/html/__swift/library/Exception/class.SWIFT_Exception.php(182): SWIFT_Exception::RenderError('Warning', 'fopen(./__swift...') #2 [internal function]: SWIFT_Exception::GlobalErrorHandler(2, 'fopen(./__swift...', '/var/www/html/_...', 414, Array) #3 /var/www/html/__swift/library/Log/class.SWIFT_Log.php(414): fopen('./__swift/logs/...', 'a+') #4 /var/www/html/__swift/library/Log/class.SWIFT_Log.php(537): SWIFT_Log->Start() #5 /var/www/html/__swift/library/class.SWIFT.php(16): SWIFT_Log->Log('1: Call to a me...') #6 [internal function]: SWIFT->ProcessShutdown() #7 {main} thrown in/var/www/html/__swift/library/Log/class.SWIFT_Log.phpon line538
     
  8. Gurpreet Singh

    Gurpreet Singh Staff Member

    Hello All,

    The reported issue has resolved now and SeLinux was the culprit here.

    Disabling the SeLinux fixed the issue.
     

Share This Page