Import from Cerb5 into Resolve

Discussion in 'Installation, setup, upgrading and importing' started by Nathan Underwood, Jul 21, 2012.

  1. Nathan Underwood

    Nathan Underwood Established Member

    My company is looking to migrate our existing Cerb5 helpdesk into Kayako Resolve. We have a trial install of Resolve on an Ubuntu LAMP server and have been very impressed with it so far. We would like to be able to import *most* of our data (Organizations, Contacts and Tickets) from Cerb5 into Resolve and this functionality seems to be supported but I've not been able to find any documentation on it. At this point, everything is contained in a sandbox, so I've got plenty of wiggle room for trial and error. I have restored a backup of my Cerb database to the MySQL instance on my (new) Resolve server and went to Admin CP -> Import -> Manage -> Cerebus Helpdesk 5 -> entered info -> Start and, almost immediately, I get the following error:

    [4096]: Argument 2 passed to View_Import::RenderProgress() must be an instance of SWIFT_ImportTable, boolean given, called in /var/www/kayako/__swift/modules/base/admin/class.Controller_Import.php on line 181 and defined (admin/class.View_Import.php:160)

    There is nothing listed in the Import Log. I've googled the error, parts of the error, and everything that I can think of but haven't had any luck and thought this would be a good opportunity to reach out the community to see if anyone else had had similar problems and, more importantly, if anyone had been able to get past it.
  2. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    Hi Nathan

    Did you receive the Impex plugin from us (ie contacted us for it)? If you didn't, you may be using an out of date one. If you did contact us for it, feel free to update your ticket with a link to this thread and one of our developers will take a look :)
  3. Nathan Underwood

    Nathan Underwood Established Member

    I don't see it. Could I trouble you to send it to me again? If so, go ahead and send it to nathan dot underwood at cybertechcafe dot net. Also, is there any documentation available on how to use it?
  4. Nathan Underwood

    Nathan Underwood Established Member

    Ok, so I found the Impex script (Cerebus5.rar) and unzipped it into kayako/__swift/library/Import/Cerberus5 (I actually renamed the original Cerebus5 directory Cerebus5.orig and then unzipped the .rar file in it's place and changed the permissions to match the original). Went into the Admin CP, rebuilt the cache (not sure why, just seemed like a good idea) and then re-tried the import but got this:

    [4096]: Argument 2 passed to View_Import::RenderProgress() must be an instance of SWIFT_ImportTable, boolean given, called in /var/www/kayako/__swift/modules/base/admin/class.Controller_Import.php on line 181 and defined (admin/class.View_Import.php:160)

    This is a practice install of Kayako that does have configurations and data in it so, if we believe it would help, I could do a reinstall. One thing that I noticed though was that I didn't see any thing that went into modules/base/admin/class.Controller_import.php. Any thoughts?
  5. Jitender Kumar

    Jitender Kumar Kayako Staff

    Hi Nathan,

    The Impex is setup to import data into a fresh Kayako Installation. Reinstall the help desk and use the import script again. If you have a ticket with Kayako, update them with the exact version of Cerberus to be imported. This will help to provide the ample Impex script.
  6. Nathan Underwood

    Nathan Underwood Established Member

    Ok, just did a clean install of Kayako. At first login, I attempted to re-run the import script and got the same error. My Cerebus helpdesk is Version 5.7.0 (Build 2012011201).
  7. Nathan Underwood

    Nathan Underwood Established Member

    Just opened a ticket on this and will reply with any progress. Has anyone had a successful import of Cerb data into Kayako?
  8. seb_pl

    seb_pl New Member

    Hello,

    Got similar issue. Fresh Kayako installation, trying to import Cerberus 5.6.3 - same error. Do you know already source of issue ? Did you fix it ?

    BR
    Seb
  9. Nathan Underwood

    Nathan Underwood Established Member

    I just checked back to see the status of the ticket but it was closed, no resolution. Not sure why it was closed and I have still not been able to import. Considering just importing my organizations and contacts via .csv and starting over :( Our experience with Cerb has deteriorated (at best) since we originally purchased it at v3.x. Cost has gone up exponentially and support seems to have just gone away. I'm starting to get concerned though that I'm jumping out of the frying pan and into the fryer. </rant>

Share This Page