1. The forum you are viewing relates to Kayako 3, which reached end of life in 2012. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (i.e. plain wrong!).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

Install on a Windows Server 2003... extremly confusing

Discussion in 'Installation and upgrading' started by Solenoid, Jun 25, 2007.

  1. eiden

    eiden New Member

    I have no idea.

    Open the first php.ini file. Edit some setting there. Restart IIS. Run phpinfo() and see if the setting has changed.
     
  2. Solenoid

    Solenoid New Member

    Yep, I got the bastard, it was C:\PHP, and the default was C:\WINDWOS. But now, after giving the key the SupportSuite, I get a blank page... display_errors is on. Do I have to install MySql too and import all the data?
     
  3. eiden

    eiden New Member

    No that shouldn't be necessary.

    Did you set short_open_tag = On ?
     
  4. Sheep

    Sheep New Member

    Try to set
    error_reporting = E_ALL

    in your php.ini
     
  5. Solenoid

    Solenoid New Member

    short_open_tag was already on and error_reporting was already E_ALL. I downloaded phpMyAdmin and its noticing me "Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly". I don't get and PHP errors and how could it be related to the webserver?
     
  6. eiden

    eiden New Member

    Could be that IUSR_<machinename> doesn't have write permissions to PHP's temp and session folders ?
     
  7. Solenoid

    Solenoid New Member

    Nope, I changed it to C:\PHP\phpsessions and it still gives me the same error.
     
  8. Solenoid

    Solenoid New Member

    Now suddently there's a nice "Cannot load mysql..." error, a staff supervisor came and checked what I've been doing, he must've done something. On to MySql installation.
     
  9. Sheep

    Sheep New Member

    make sure that
    extension=php_mysql.dll
    in php.ini isn't commented (with ";")
     
  10. Solenoid

    Solenoid New Member

    New day, new problem(s). I'm havng trouble getting MySql to start. It seems everything is ok, but phpMyAdmin still gives me the same error ("Cannot load mysql extension"). I've uncommented the extension=php_mysql.dll in php.ini, put the right directory for the extensions (extension_dir="C:\PHP\ext"), but no success. What would be the usual next step before the head-wall procedure?
     
  11. eiden

    eiden New Member

    Is the extension loaded? Do you see it in phpinfo()? Remember that you have to restart IIS when you modify php.ini.

    If you used the installer, you can just run the setup again and install the mysql extension.
     
  12. Solenoid

    Solenoid New Member

    Wait, restarting the server helped, I'm sorry if anybody wasted their lives on me...
     
  13. eiden

    eiden New Member

    No problem ;)
     
  14. Solenoid

    Solenoid New Member

    Slowly but surely this is looking better and better. phpMyAdmin denies access with a 1045 code, I know I have to put a password somewhere, but where? C:\PHP\config.inc.php - done, C:\PHP\libraries\config.inc.php - done, I can access the MySql command line with my password and all, but phpMyAdmin refuses. Also SupportSuite gives me a nice "Unknown database 'swift'" error, after I provided the password in the SupportSuite configuration page... so my password is correct. This is the last straight line...
     
  15. Solenoid

    Solenoid New Member

    phpMyAdmin doesn't work in the phpMyAdmin\index.php, but once I click to open a new window it does... oh well. Now while setting up SupportSuite in the Auto Setup part it fails everything, the error after "Creating table registry" is "Reason: BLOB/TEXT column 'data' can't have a default value", seems I have to start over with an older PHP or something.
     
  16. Solenoid

    Solenoid New Member

  17. Solenoid

    Solenoid New Member

    Silly me, I found it in the MYSQL folder, it's "my.ini" not "mysql.ini". Changed the sql-mode to "" and... nothing, still the same error. I restarted IIS, do I have to restart something else (if yes, how)?
     
  18. Solenoid

    Solenoid New Member

    It works, at last... with a bunch of errors, actually one... it wants the correct licence key, since I made a test server with a name I invented, but gave it the localhost key it's pretty ugly. But I can see the login form and all.
     
  19. Solenoid

    Solenoid New Member

    I'm terribly sorry, this last one is really bad luck. I found out how to change the product key and this part of the errors went away, but all the others stayed: Warning: fwrite(): supplied argument is not a valid stream resource in ..., it has to do with permissions again, but the SupportSuite folder is readable and writable.
     
  20. Solenoid

    Solenoid New Member

    Got it, I had to give some cache permissions to the IUSR, I didn't know what it was, but while messing around I found it: right click in Windows Explorer, click properties, security tab and set the Server Operators permissions to Full Control. I hope it helps somebody.

    You really helped me out guys, cheers.
     

Share This Page