Mail Parser not seeing email queue

Discussion in 'Installation and setup (Kayako Download)' started by tech_services, Jul 27, 2011.

  1. frankbackes

    frankbackes Established Member

    Now I get this what is totaly redicolous:
    [Warning]: fsockopen() [function.fsockopen]: unable to connect to tcp://imap.DomainRemoved.de:587 (Connection timed out) (Transport/StreamBuffer.php:250)

    As port 587 is for SMTP and not for IMAP. So where could this setting be. In AP under settings Email settings it's setup:
    [​IMG]

    And the mail queue settings are:
    [​IMG]

    I can't see where the settings could be located. That has IMAP with 587 as port to fetch.

    I get that error when I go on a ticket and do a reply with the mark "Send mail" is checked. As soon I uncheck it I don't get the error. So it must somewhere bewhere the sent settings are filled in. And on that location I have to change Imap.***.de to smpt.***.de but I don't know where it could be.

    Thank you
     
  2. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Frank,

    Try changing "use queue smtp server" to no

    Gary
     
  3. frankbackes

    frankbackes Established Member

    Ok yes that solved the issue of error message but now if I understand well it will tke the mail configured mail in settings mail settings for all queues so all queues will end up sending back with that adress and ppl replying w sent to that adress and the mail parser will no longer fetch the mails ?


    Actually have you eaten the Manual of Kayako that you know all ? :)
     
  4. Gary McGrath

    Gary McGrath Kayako Staff Staff Member

    Hi Frank,

    IMAP is actually a receiving protocol, it has no ability to actually send mail ( which is why I have always been confused why there is an option to use it as the queues smtp server, its technically not possible, which is why it errors out )

    I beleive there is a check on outbound emails in kayako to detect the queue address, and send out using it ( although not 100% sure, as we dont use more than one queue )

    What kayako really needs is an option to set SMTP server per queue, with all the settings it might need, but sadly thats not possible atm.

    Gary
     
  5. frankbackes

    frankbackes Established Member

    ok nice then it's fine
     

Share This Page