1. Kayako Download customers: we will continue to develop and support Kayako Download beyond July 2017, alongside the new Kayako for existing customers.

    Find out more.

No Site Visitors

Discussion in 'Kayako Desktop' started by Luke Johnson, Jun 11, 2015.

  1. Luke Johnson

    Luke Johnson New Member

    For some reason we can only see visitors to our website when its accessed from within our own network. No external visitors are showing up at all. Ive tried all I can think of to try and get it working again but nothing I seem to try help. Its currently all running on a Linux box.

    Any help would be greatly appreciated.

    Kind regards,
    Luke Johnson
     
  2. Gary McGrath

    Gary McGrath Staff Member

    Hi Luke,

    Can you submit a support request at support.kayako.com and we will take a look directly at it for you, as it could be a number of things, so we will need to check your configuration.

    Gary
     
  3. Luke Johnson

    Luke Johnson New Member

    I would but ive already submitted about 3 and im not getting anywhere.

    ive tried this:

    If you have set the helpdesk URL on https, then to access it via http, you're required to change it to http from the database. Here are the steps to perform it:

    1) Connect to the help desk database using MySQL CLI, the details of database can be found under '__swift/config/config.php' file:

    mysql -u db_username -p db_name
    password: db_password

    2) List the existing help desk URL:

    select data from swsettings where vkey='general_producturl';

    3) Change the product URL to "http://yourdomain/" as below:

    update swsettings set data='http://yourdomain/' where vkey='general_producturl';(make sure to add '/' at the end)

    4) exit

    5) Rebuild the help desk cache by accessing the following link from the web
    browser:

    http://yourdomain/staff/index.php?/Core/Default/RebuildCache

    Once you change your help desk product URL to http, live chat will also run on http. But you will need to replace all the live chat tags that exists with https. You can generate new tags from: Admin Interface > Tag Generator. Make sure that 'Use secure URLs (https://)' option is set to 'No' while generating the tag. For more help on generating live chat tags, you may refer to: https://kayako.atlassian.net/wiki/pages/viewpage.action?pageId=5734704

    Feel free to update me if you have any further concerns.

    Did not work, do you have any more suggestions? I wouldnt mind either as we have just bought a new support contract.
     
  4. Gary McGrath

    Gary McGrath Staff Member

    hmm, my first thought would be that the live chat code is simply not managing to connect back to the helpdesk.

    If you use Chrome, and open your website, then open the chrome developer tools, does the console list any errors?

    If you then goto the network tab, you should be able to see the live chat calling URL, does it look right? ( correct domain etc.. )

    Gary
     
  5. Luke Johnson

    Luke Johnson New Member

    Im getting a NET connection refused showing up in the dev tools. For some reason it cant see that the server is online externally. Internally it works fine.
     
  6. Luke Johnson

    Luke Johnson New Member

    The button that appears on our website to start a chat shows it as being offline too.
     
  7. Gary McGrath

    Gary McGrath Staff Member

    Ok, so it sounds like your webserver is simply not allowing access in some way, can you get to your helpdesk from the outside using the URL? ( e.g. helpdeskdomain.com ? )

    Gary
     
  8. Luke Johnson

    Luke Johnson New Member

    Hi Gary,

    I cannot access the webserver externally.
     
  9. Gary McGrath

    Gary McGrath Staff Member

    Ah ok,

    so this is what needs fixing, if you cannot access the webserver, then obviously neither can the live chat tag code :)

    Did you make sure to forward ports 80 and 443 from your internet router to your webservers internal IP address?

    Have you ensured that your helpdesk domain name resolves to your external IP ( coming from your internet router )

    Gary
     

Share This Page