1. This sub-forum relates to Kayako 3, which is now end-of-life. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (no longer applicable).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

probles upgrading from 3.10.02 STABLE to May 7 build of 3.10.02 CVS

Discussion in 'Installation and upgrading' started by tommy, May 9, 2007.

  1. tommy

    tommy Member

    I tried upgrading our 3.10.02 STABLE installation of SupportSuite to the May 7 version of 3.10.02 CVS release to take advantage of the May 2 fix for XSS Vulnerabilities on trigger events, but got the following error:

    Fatal error: Cannot instantiate non-existent class c_s in/opt/supportsuite-3_10_02-cvs-sendopen/upload/setup/includes/functions.php on line 62

    Pertinent installation information:

    Sun Solaris SPARC 5.9
    PHP v4.4.7 <- recent upgrade that works fine with 3.10.02 STABLE
    Zend optimizer 3.2.8 < - recent upgrade that works fine with 3.10.02 STABLE
    MySQL v 5.0.37

    Has anyone experienced this error; know what the error means; and/or have suggestions of what needs to be done to upgrade?

    Thanks in advance!
  2. Torbjörn S.

    Torbjörn S. Reputed Member

    I also have trouble when trying to upgrade to latest cvs. My problem is that I only get a white page so I cant even start the setup.
  3. craigbrass

    craigbrass New Member

    I would strongly advise against upgrading to a CVS. I would wait until the next stable version is available. CVS versions are not guaranteed to work and there may be problems with them such as this.
  4. Mahesh Salaria

    Mahesh Salaria Developer

    We have some problems with our zend encoded builds. It is recommended to use ioncube builds.

    Please create a support ticket at services AT kayako.com if you get any issues regarding installations. Our services team will try to fix your issues ASAP.

    Regards,
  5. tommy

    tommy Member

    Hi Craig,

    re:
    I appreciate your caution against running CVS versions; our typical posture is to only run STABLE distributions. The reason I tried to upgrade to the latest CVS was to take advantage of the 'XSS Vulnerabilities on trigger events' fix reported in the Changelog on May 2.

    Hi Mahesh,

    re:
    I will open a Kayako ticket on the Zend-related upgrade problem I ran into. I would rather not switch from Zend-encoded distributions to Ioncube-encoded ones at this time, however. I am, of course, willing to switch to Ioncube-endoded distributions IF Kayako is now recommending to not use Zend.
  6. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    The Zend versions of the software more often than not work fine - however, there is a problem we have hit with the latest run of the encode so if you are desperately wanting the run the latest CVS version, we recommend you use the IonCube encoded version. The issue is being worked on.
  7. KPotter

    KPotter New Member

    When can we expect a new STABLE build that includes all of the fixes since the 5th of March (especially the XSS vulnerability)?

    There have been so many fixes since the last stable build that are very important for us -- but I don't wish to upgrade to a CVS build on my production servers.

    Isn't it about time for a STABLE release?
  8. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    Hi KPotter,

    A new stable release is due soon.
  9. Torbjörn S.

    Torbjörn S. Reputed Member

    Is there any news about the zendversion of cvs?
    There are alot in there that we need to test before we put it (or the next stable) in our live enviroment.
  10. craigbrass

    craigbrass New Member

    I think they fixed it. Try downloading a CSV version and installing it separate to your live installation and see if it installs fine.
  11. Jamie Edwards

    Jamie Edwards Chief Limey Staff Member

    Correct - it has been fixed and I tested this two nights ago. Don't forget you can always do a test install of the CVS software within your domain name.
  12. rrnworks

    rrnworks Established Member

    I'm glad there is finally a fix. I was reporting this issue awhile ago, and always got the response that I just needed to upgrade my Zend version.

    How do we do a test install within our domain name?
  13. craigbrass

    craigbrass New Member

    Just set it up in a folder like /testinstall/ and make sure there is no problems installing.

Share This Page