1. The forum you are viewing relates to Kayako 3, which reached end of life in 2012. Please be aware that a lot of information relating to features, sales and the roadmap in the Kayako 3 forums is now outdated or defunct (i.e. plain wrong!).

    If unsure about anything, please create a new thread or contact us.

    You can visit the main forums for the latest Kayako here.

wget Dos Window Popup Problem

Discussion in 'Installation and upgrading' started by blaforce, Aug 23, 2007.

  1. blaforce

    blaforce New Member

    See last post for how I setup the Task Scheduler to work with php-win.exe instead of wget.
    Has anyone been able to stop the dos window from flashing up in Windows? It's very tacky to have a dos window pop up every 5 minutes on a server when running the cron tasks under windows. I'm using the -q option in the wget command line put the dos window still opens and closes on the console.
    Thanks, Brian
     
  2. richm

    richm New Member

    Hi Brian,

    I don't get any popup running wget as a scheduled jon on winserver2003

    Here's what I'm using to run it:

    C:\wget\wget.exe -O nul -a wgetLog "http://yoursite.com/support/cron/index.php?_t=parser"

    Maybe sending the output to nul ( "-O nul" option) will stop it?

    HTH,

    Rich
     
  3. blaforce

    blaforce New Member

    Then it must be because I'm getting an error: Unsupported Scheme. "D:\Programs Files\GnuWin32\bin\wget.exe" -O nul -a wgetLog.txt https://localhost/esupport/cron/index.php?_t=parser
    Thanks for posting your command line. The log shows me the problem. I thought it was working.
    Update: looks like some versions of wget do not work with https urls.
     
  4. richm

    richm New Member

    Looks like you could also try to add:

    C:\wget\wget.exe -O nul -a wgetLog --no-check-certificate "https://s
     
  5. blaforce

    blaforce New Member

    No errors written to the error log but it still flashes a dos window on the server. I will need to run some tests to see if it runs a task. I had to install wget 1.10.2. I think I use localhost with the --no-check-certificate option. Thanks again!
     
  6. richm

    richm New Member

    Can't seem to pull a version out the wget copy i have but it's 325k (332,800 bytes)

    Running with SSL here also.

    Rich
     
  7. blaforce

    blaforce New Member

    Looks like it's working now. I had to setup a www DNS entry and add the site to local internet sites in IE (for testing). Log says it ran ok but has a warning "unable to get issuer certificate." This may be causing the quick dos pop window. Don't know why I get the warning because I now use the proper website url in the command line.
     
  8. blaforce

    blaforce New Member

    No errors in the wget log but the dos window still pops up and closes.
    One other thing. One task shows in the eSupport log without a title??
     
  9. blaforce

    blaforce New Member

    Well, going on vacation so I will try php-win.exe when I get back. It doesn't use a dos window.
     
  10. blaforce

    blaforce New Member

    Ok, I finally got it. Scheduled Tasks:
    Run: D:\php\php-win.exe -c C:\windows\php.ini -f D:\Inetpub\kayako\cron\index.php
    Start in: D:\Inetpub\kayako\cron
    Hope this helps someone else.
    Brian
     
  11. craigbrass

    craigbrass New Member

    Thanks for sharing Brian!
     
  12. paisano2k

    paisano2k New Member

    Working in Windows Server 2003

    I got it to work by downloading wget-1.10.1 and installing it using the windows installation executable
    ******************************************************

    after installing wget-1.10.1.exe and setting the following in a scheduled task:

    Start in: “C:\Program Files\GnuWin32\bin”

    Run: “C:\Program Files\GnuWin32\bin\wget.exe” –q –O nul http://www.yourdomain.com/support/cron/index.php?_t=parser

    Please note where the quotation marks are! If you have them anywhere else, it won't work. There is a space after the last quotation mark in the RUN command line before the -q and also after the word nul, other than that, you should be good to go!



    Make sure you have the quotes ("") where they are, or it won't work.




    M.
     
  13. jeffshead

    jeffshead Established Member


    I tried everything in this post. I could not get any of them to work. The list below includes most of the scenarios I have tried. The only one I can get to work is the first one, but that "pesky" DOS window flashes everytime the task runs:

    Code:
     
    Works:
    Run: C:\wget\wget.exe -q -O nul -a wgetLog "[URL]http://www.mysite.com/support/cron/index.php?_t=parser[/URL]"
    Start in: C:\wget
    ===================
    Test 1
    C:\wget\wget.exe -O nul -a wgetLog "C:\www\vhosts\_static\mysite.com\support\cron\index.php?_t=parser"
    C:\wget
    ===================
    Test2
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f C:\www\vhosts\_static\mysite.com\support\cron\index.php
    C:\www\vhosts\_static\mysite.com\support\cron
    ====================
    Test3
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f "C:\www\vhosts\_static\mysite.com\support\cron\index.php"
    C:\www\vhosts\_static\mysite.com\support\cron
    ====================
    Test4
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f "C:\www\vhosts\_static\mysite.com\support\cron\index.php?_t=parser"
    C:\www\vhosts\_static\mysite.com\support\cron
    ====================
    Test5
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f "[URL]http://www.mysite.com/support/cron/index.php?_t=parser[/URL]"
    C:\www\vhosts\_static\mysite.com\support\cron
    ====================
    Test6
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f "[URL]http://www.mysite.com/support/cron/index.php?_t=parser[/URL]"
    C:\www\php5
    ===================
    Test7
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f C:\www\vhosts\_static\mysite.com\support\cron\index.php
    C:\www\php5
    ===================
    Test8
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f C:\www\vhosts\_static\mysite.com\support\cron\index.php?_t=parser
    C:\www\php5
    ===================
    Test9
    C:\www\php5\php-win.exe -c C:\php5\php.ini -f "C:\www\vhosts\_static\mysite.com\support\cron\index.php?_t=parser"
    C:\www\php5
    ===================
    Test10
    C:\wget\wget.exe -O nul -a wgetLog --no-check-certificate "[URL]https://www.mysite.com/support/cron/index.php?_t=parser[/URL]"
    C:\wget
    ===================
    Test11
    C:\wget\wget.exe -O nul -a wgetLog "[URL]https://www.mysite.com/support/cron/index.php?_t=parser[/URL]"
    C:\wget
    
    I really wanted to use a local path instead of a URL since everything is on the same box. Or at least use SSL, but I cannot get it to work.

    Is it possible to use a local path, SSL or at least get rid of the DOS window issue?


    "https://www.mysite.com/support/cron/index.php?_t=parser" does work when accessing via a web browser. Wget does not like it even when using "--no-check-certificate".
     

Share This Page